$re = '/(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*/';
$str = 'cast (mara.attyp as prodcategory preserving type ) as ProductCategory';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;