# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.\\/public\\/uploads\\/avatar(\\|\\/)//gi;t' <<< "./public/uploads/avatar\php17C_552334c997e50.png"