// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^.\/public\/uploads\/avatar(\\|\/)").unwrap();
let string = "./public/uploads/avatar\\php17C_552334c997e50.png";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}