import Foundation
let pattern = #"^.\/public\/uploads\/avatar(\\|\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"./public/uploads/avatar\php17C_552334c997e50.png"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)