$re = '/^.\/public\/uploads\/avatar(\\\\|\/)/i';
$str = './public/uploads/avatar\\php17C_552334c997e50.png';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;