use strict;
my $str = './public/uploads/avatar\\php17C_552334c997e50.png';
my $regex = qr/^.\/public\/uploads\/avatar(\\|\/)/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";