re = /^.\/public\/uploads\/avatar(\\|\/)/i
str = './public/uploads/avatar\\php17C_552334c997e50.png'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result