#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)"
Local $sString = "23123<123>" & @CRLF & _
" 123 <1>" & @CRLF & _
"123 <123>" & @CRLF & _
" 123<12>" & @CRLF & _
"<123>" & @CRLF & _
" <1>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")