const regex = /\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(\\d{1,5})?\\s*(?:<(?<pri>\\d{1,3})>)', 'gim')
const str = `23123<123>
123 <1>
123 <123>
123<12>
<123>
<1>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}