// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)").unwrap();
let string = "23123<123>
123 <1>
123 <123>
123<12>
<123>
<1>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}