$re = '/\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)/im';
$str = '23123<123>
123 <1>
123 <123>
123<12>
<123>
<1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);