using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)";
string input = @"23123<123>
123 <1>
123 <123>
123<12>
<123>
<1>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}