import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\\d{1,5})?\\s*(?:<(?<pri>\\d{1,3})>)";
final String string = "23123<123>\n"
+ " 123 <1>\n"
+ "123 <123>\n"
+ " 123<12>\n"
+ "<123>\n"
+ " <1>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}