package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)`)
var str = `23123<123>
123 <1>
123 <123>
123<12>
<123>
<1>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}