using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMac\b.*\bExchangeWebServices\b";
string input = @"This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.
This expression should not match Macintosh and ExchangeWebServices!
Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);
Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);
Mac OS X/10.5; ExchangeWebServices/6.0 (243);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}