use strict;
my $str = 'This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.
This expression should not match Macintosh and ExchangeWebServices!
Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);
Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);
Mac OS X/10.5; ExchangeWebServices/6.0 (243);';
my $regex = qr/\bMac\b.*\bExchangeWebServices\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}