import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMac\\b.*\\bExchangeWebServices\\b";
final String string = "This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.\n"
+ "This expression should not match Macintosh and ExchangeWebServices!\n"
+ "Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);\n"
+ "Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);\n"
+ "Mac OS X/10.5; ExchangeWebServices/6.0 (243);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}