const regex = /\bMac\b.*\bExchangeWebServices\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bMac\\b.*\\bExchangeWebServices\\b', 'g')
const str = `This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.
This expression should not match Macintosh and ExchangeWebServices!
Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);
Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);
Mac OS X/10.5; ExchangeWebServices/6.0 (243);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}