// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bMac\b.*\bExchangeWebServices\b").unwrap();
let string = "This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.
This expression should not match Macintosh and ExchangeWebServices!
Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);
Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);
Mac OS X/10.5; ExchangeWebServices/6.0 (243);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}