# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#[0-9a-fA-F]{6,6};//;t' <<< "<a href=\"//10.1.1.175/Intranetv2/content_kostenstellen.php\" style=\"margin-top:10px; background-color:#800000; border-color:#800000;\" class=\"btn btn-warning\">Kostenstellen</a>"