import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#[0-9a-fA-F]{6,6};";
final String string = "<a href=\"//10.1.1.175/Intranetv2/content_kostenstellen.php\" style=\"margin-top:10px; background-color:#800000; border-color:#800000;\" class=\"btn btn-warning\">Kostenstellen</a>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}