import Foundation
let pattern = ##"#[0-9a-fA-F]{6,6};"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<a href="//10.1.1.175/Intranetv2/content_kostenstellen.php" style="margin-top:10px; background-color:#800000; border-color:#800000;" class="btn btn-warning">Kostenstellen</a>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}