$re = '/#[0-9a-fA-F]{6,6};/';
$str = '<a href="//10.1.1.175/Intranetv2/content_kostenstellen.php" style="margin-top:10px; background-color:#800000; border-color:#800000;" class="btn btn-warning">Kostenstellen</a>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;