// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#[0-9a-fA-F]{6,6};").unwrap();
let string = "<a href=\"//10.1.1.175/Intranetv2/content_kostenstellen.php\" style=\"margin-top:10px; background-color:#800000; border-color:#800000;\" class=\"btn btn-warning\">Kostenstellen</a>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}