using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[0-9a-fA-F]{6,6};";
string substitution = @"";
string input = @"<a href=""//10.1.1.175/Intranetv2/content_kostenstellen.php"" style=""margin-top:10px; background-color:#800000; border-color:#800000;"" class=""btn btn-warning"">Kostenstellen</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}