# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#[0-9a-fA-F]{6,6};"
test_str = "<a href=\"//10.1.1.175/Intranetv2/content_kostenstellen.php\" style=\"margin-top:10px; background-color:#800000; border-color:#800000;\" class=\"btn btn-warning\">Kostenstellen</a>"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.