# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\w+)\b.*?>.*?<\\/\1>(*SKIP)(*F)|>/something/gs;t' <<< "<div class=\"test\">here is text
</div> > need to parse it"