$re = '/<(\w+)\b.*?>.*?<\/\1>(*SKIP)(*F)|>/s';
$str = '<div class="test">here is text
</div> > need to parse it';
$subst = "something";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;