import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+)\\b.*?>.*?<\\/\\1>(*SKIP)(*F)|>";
final String string = "<div class=\"test\">here is text\n\n"
+ "</div> > need to parse it";
final String subst = "something";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}