use strict;
my $str = '<div class="test">here is text
</div> > need to parse it';
my $regex = qr/<(\w+)\b.*?>.*?<\/\1>(*SKIP)(*F)|>/sp;
my $subst = 'something';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";