using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)\b.*?>.*?<\/\1>(*SKIP)(*F)|>";
string substitution = @"something";
string input = @"<div class=""test"">here is text
</div> > need to parse it";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}