import Foundation
let pattern = #"<(\w+)\b.*?>.*?<\/\1>(*SKIP)(*F)|>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<div class="test">here is text
</div> > need to parse it
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"something"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)