const regex = /<(\w+)\b.*?>.*?<\/\1>(*SKIP)(*F)|>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)\\b.*?>.*?<\\\/\\1>(*SKIP)(*F)|>', 'gs')
const str = `<div class="test">here is text
</div> > need to parse it`;
const subst = `something`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);