#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<(\w+)\b.*?>.*?<\/\1>(*SKIP)(*F)|>"
Local $sString = "<div class="test">here is text" & @CRLF & _
"" & @CRLF & _
"</div> > need to parse it"
Local $sSubst = "something"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)