#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<span class="ccd">[^<]*<\/span>"
Local $sString = "<td class="col-2">" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" 5 doors, 6 Speed manual," & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" <span class="pc">" & @CRLF & _
" from £24,270" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" <span class="ccd">" & @CRLF & _
" from £24,215" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" <a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>" & @CRLF & _
" <br>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" 5 doors, 7 Speed auto DSG," & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" <span class="pc">" & @CRLF & _
" from £25,685" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" <span class="ccd">" & @CRLF & _
" from £25,630" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" <a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>" & @CRLF & _
" <br>" & @CRLF & _
" " & @CRLF & _
" </td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")