use strict;
my $str = '<td class="col-2">
5 doors, 6 Speed manual,
<span class="pc">
from £24,270
</span>
<span class="ccd">
from £24,215
</span>
<a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>
<br>
5 doors, 7 Speed auto DSG,
<span class="pc">
from £25,685
</span>
<span class="ccd">
from £25,630
</span>
<a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>
<br>
</td>';
my $regex = qr/<span class="ccd">[^<]*<\/span>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}