import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"ccd\">[^<]*<\\/span>";
final String string = "<td class=\"col-2\">\n\n"
+ " \n\n"
+ " 5 doors, 6 Speed manual,\n\n"
+ " \n"
+ " <span class=\"pc\">\n"
+ " from £24,270\n"
+ " </span>\n"
+ " \n\n"
+ " <span class=\"ccd\">\n"
+ " from £24,215\n"
+ " </span>\n"
+ " \n"
+ " <a href=\"/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366\" class=\"tax-calculator ccd vw-btn btn-no-border\"><span class=\"vw-icon-link-small\">Get a company car tax quote</span></a>\n"
+ " <br>\n"
+ " \n\n"
+ " 5 doors, 7 Speed auto DSG,\n\n"
+ " \n"
+ " <span class=\"pc\">\n"
+ " from £25,685\n"
+ " </span>\n"
+ " \n\n"
+ " <span class=\"ccd\">\n"
+ " from £25,630\n"
+ " </span>\n"
+ " \n"
+ " <a href=\"/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374\" class=\"tax-calculator ccd vw-btn btn-no-border\"><span class=\"vw-icon-link-small\">Get a company car tax quote</span></a>\n"
+ " <br>\n"
+ " \n"
+ " </td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}