using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=""ccd"">[^<]*<\/span>";
string input = @"<td class=""col-2"">
5 doors, 6 Speed manual,
<span class=""pc"">
from £24,270
</span>
<span class=""ccd"">
from £24,215
</span>
<a href=""/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366"" class=""tax-calculator ccd vw-btn btn-no-border""><span class=""vw-icon-link-small"">Get a company car tax quote</span></a>
<br>
5 doors, 7 Speed auto DSG,
<span class=""pc"">
from £25,685
</span>
<span class=""ccd"">
from £25,630
</span>
<a href=""/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374"" class=""tax-calculator ccd vw-btn btn-no-border""><span class=""vw-icon-link-small"">Get a company car tax quote</span></a>
<br>
</td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}