import re
regex = re.compile(r"<span class=\"ccd\">[^<]*<\/span>", flags=re.MULTILINE)
test_str = ("<td class=\"col-2\">\n\n"
" \n\n"
" 5 doors, 6 Speed manual,\n\n"
" \n"
" <span class=\"pc\">\n"
" from £24,270\n"
" </span>\n"
" \n\n"
" <span class=\"ccd\">\n"
" from £24,215\n"
" </span>\n"
" \n"
" <a href=\"/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366\" class=\"tax-calculator ccd vw-btn btn-no-border\"><span class=\"vw-icon-link-small\">Get a company car tax quote</span></a>\n"
" <br>\n"
" \n\n"
" 5 doors, 7 Speed auto DSG,\n\n"
" \n"
" <span class=\"pc\">\n"
" from £25,685\n"
" </span>\n"
" \n\n"
" <span class=\"ccd\">\n"
" from £25,630\n"
" </span>\n"
" \n"
" <a href=\"/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374\" class=\"tax-calculator ccd vw-btn btn-no-border\"><span class=\"vw-icon-link-small\">Get a company car tax quote</span></a>\n"
" <br>\n"
" \n"
" </td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")