// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span class="ccd">[^<]*<\/span>"#).unwrap();
let string = "<td class=\"col-2\">
5 doors, 6 Speed manual,
<span class=\"pc\">
from £24,270
</span>
<span class=\"ccd\">
from £24,215
</span>
<a href=\"/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366\" class=\"tax-calculator ccd vw-btn btn-no-border\"><span class=\"vw-icon-link-small\">Get a company car tax quote</span></a>
<br>
5 doors, 7 Speed auto DSG,
<span class=\"pc\">
from £25,685
</span>
<span class=\"ccd\">
from £25,630
</span>
<a href=\"/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374\" class=\"tax-calculator ccd vw-btn btn-no-border\"><span class=\"vw-icon-link-small\">Get a company car tax quote</span></a>
<br>
</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}