const regex = /<span class="ccd">[^<]*<\/span>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span class="ccd">[^<]*<\\\/span>', 'mg')
const str = `<td class="col-2">
5 doors, 6 Speed manual,
<span class="pc">
from £24,270
</span>
<span class="ccd">
from £24,215
</span>
<a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>
<br>
5 doors, 7 Speed auto DSG,
<span class="pc">
from £25,685
</span>
<span class="ccd">
from £25,630
</span>
<a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>
<br>
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}