using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})";
string substitution = @"strftime(""%FT%T"", $5, $4, $3, $2, $1, (localtime(time))[5])";
string input = @"Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}