# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})"
test_str = ("Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log\n"
"INFO: Closing Spring root WebApplicationContext\n"
"Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log\n"
"INFO: Closing Spring root WebApplicationContext")
subst = "strftime(\"%FT%T\", $5, $4, $3, $2, $1, (localtime(time))[5])"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.