const regex = /(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{3}) {1,2}(\\d{1,2}) (\\d{2}):(\\d{2}):(\\d{2})', '')
const str = `Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext`;
const subst = `strftime("%FT%T", $5, $4, $3, $2, $1, (localtime(time))[5])`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);