package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})`)
var str = []byte(`Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext`)
var substitution = []byte("strftime("%FT%T", $5, $4, $3, $2, $1, (localtime(time))[5])")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}