import Foundation
let pattern = #"(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"strftime("%FT%T", $5, $4, $3, $2, $1, (localtime(time))[5])"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}