// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})").unwrap();
let string = "Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext";
let substitution = "strftime(\"%FT%T\", $5, $4, $3, $2, $1, (localtime(time))[5])";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}