# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<string .*?>(.*?)<\\/string>/$1/g;t' <<< "<string xmlns=\"http://schemas.microsoft.com/2003/10/Serialization/\">तुम्हारा नाम क्या है</string>"