use strict;
my $str = '<string xmlns="http://schemas.microsoft.com/2003/10/Serialization/">तुम्हारा नाम क्या है</string>';
my $regex = qr/<string .*?>(.*?)<\/string>/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";