import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<string .*?>(.*?)<\\/string>";
final String string = "<string xmlns=\"http://schemas.microsoft.com/2003/10/Serialization/\">तुम्हारा नाम क्या है</string>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}